Contents

glyphsLib 6.7.1

0

A bridge from Glyphs source files (.glyphs) to UFOs

A bridge from Glyphs source files (.glyphs) to UFOs

Stars: 175, Watchers: 175, Forks: 51, Open Issues: 177

The googlefonts/glyphsLib repo was created 8 years ago and the last code push was 18 hours ago.
The project is popular with 175 github stars!

How to Install glyphslib

You can install glyphslib using pip

pip install glyphslib

or add it to a project with poetry

poetry add glyphslib

Package Details

Author
James Godfrey-Kittle
License
Apache Software License 2.0
Homepage
https://github.com/googlefonts/glyphsLib
PyPi:
https://pypi.org/project/glyphsLib/
GitHub Repo:
https://github.com/googlefonts/glyphsLib

Classifiers

  • Multimedia/Graphics
  • Multimedia/Graphics/Editors/Vector-Based
  • Multimedia/Graphics/Graphics Conversion
No  glyphslib  pypi packages just yet.

Errors

A list of common glyphslib errors.

Code Examples

Here are some glyphslib code examples and snippets.

GitHub Issues

The glyphslib package has 177 open issues on GitHub

  • Anchors propagation for Arabic mark ligatures
  • Different alternate layers to components not supported
  • Can't export with smart component
  • bad interpolation with intermediate layers
  • Glyphs3
  • Support (or don't) Glyphs-specific variable feature syntax
  • [glyphdata] handle production names for ligatures with script suffixes

See more issues on GitHub